GetSplitRegionMaximum Method


Returns the proportional location of the maximum boundary of the specified split crop region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public double GetSplitRegionMaximum(
	int regionIndex
)
Visual Basic
Public Function GetSplitRegionMaximum ( _
	regionIndex As Integer _
) As Double
Visual C++
public:
double GetSplitRegionMaximum(
	int regionIndex
)

Parameters

regionIndex
Type: System Int32
Index of region to be split horizontally (numbering starts with 0).

Return Value

A value from 0 to 1 representing the maximum location for the regions split boundary. This number represents the location as a ratio along the non-split rectangular crop.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The provided region index is invalid.

See Also