SetProjectPosition Method


Sets the coordinates of a point in the ProjectLocation's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)

Syntax

C#
public void SetProjectPosition(
	XYZ point,
	ProjectPosition position
)
Visual Basic
Public Sub SetProjectPosition ( _
	point As XYZ, _
	position As ProjectPosition _
)
Visual C++
public:
void SetProjectPosition(
	XYZ^ point, 
	ProjectPosition^ position
)

Remarks

When setting this value, the transformations applied to the location are modified such that the passed point becomes the specified North/South, East/West and Elevation, and the coordinate transform will have the designated angular rotation. This is similar to the Revit command "Specify Coordinates at Point".

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException Unable to use the project position's transform to calculate the point.

See Also