TextElement Class


Base class representing text elements in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public class TextElement : Element
Visual Basic
Public Class TextElement _
	Inherits Element
Visual C++
public ref class TextElement : public Element

Remarks

TextElement is a base class for other annotation classes, like TextNote, which have additional, more specific functionality.

Inheritance Hierarchy

See Also