Creates a new ImageType element and loads the image into it.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- imagePath
- Type: System String
A path to an image file to load.
Return Value
The new ImageType.Remarks
The ImageType will be created but will not be placed into any view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | imagePath is an empty string. -or- The given imagePath is not a valid image file to load. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | The given imagePath does not exist. |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |