XVector Property


The X-vector of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public XYZ XVector { get; }
Visual Basic
Public ReadOnly Property XVector As XYZ
	Get
Visual C++
public:
property XYZ^ XVector {
	XYZ^ get ();
}

Remarks

Note that the cross product of X-vector and Y-vector may result in the reverse of the FaceNormal vector depending upon how Revit has structured this particular face.

See Also