Constructs an instance of FilterStringRule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- valueProvider
- Type: Autodesk.Revit.DB FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
- evaluator
- Type: Autodesk.Revit.DB FilterStringRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests for strings such as begins-with, ends-with, contains, equal, etc.
- ruleString
- Type: System String
The user-supplied string against which strings from a Revit document will be tested.
- caseSensitive
- Type: System Boolean
If true, string comparisons will be done case-sensitively.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |