GetRodAttachedElementId Method


Gets the id of the attached component for the specified rod.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
public LinkElementId GetRodAttachedElementId(
	int rodIndex
)
Visual Basic
Public Function GetRodAttachedElementId ( _
	rodIndex As Integer _
) As LinkElementId
Visual C++
public:
LinkElementId^ GetRodAttachedElementId(
	int rodIndex
)

Parameters

rodIndex
Type: System Int32
The index of the specified rod.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
Autodesk.Revit.Exceptions InvalidOperationException The rods do not attached to any structue.

See Also