Reports if Analytical Auto-detect for the given direction is enabled.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- direction
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction in which Auto-detect behavior may be enabled.
Return Value
True if enabled in the given direction, false otherwise.Remarks
Just because Auto-detect is enabled in one direction, that does not mean that it is enabled in a different direction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | direction is invalid for Analytical Auto-detect. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |