ExternalApplicationException Class


The exception that is thrown when an issue in the Add-Ins resulted in an unexpected error.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ExternalApplicationException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class ExternalApplicationException _
	Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class ExternalApplicationException : public ApplicationException

Remarks

Please contact your external application provider with the information about what led to this exception.

Inheritance Hierarchy

See Also