Autodesk.Revit.DB.Mechanical Namespace


Classes

Class Description
Public class Duct
A duct in the Autodesk Revit MEP product.
Public class DuctFittingAndAccessoryConnectorData
The input data used by external servers for calculation of the duct fitting and duct accessory coefficient.
Public class DuctFittingAndAccessoryData
The input data used by external servers for calculation of the duct fitting and duct accessory coefficient.
Public class DuctFittingAndAccessoryPressureDropData
The input and output data used by external servers for calculation of the duct fitting and duct accessory pressure drop.
Public class DuctFittingAndAccessoryPressureDropItem
A flow path of the duct/pipe fitting and accessory. It is defined by the begin connector and end connector.
Public class DuctInsulation
Represents insulation applied to the outside of a given duct , fitting or accessory.
Public class DuctInsulationType
This class represents a duct insulation type in Autodesk Revit.
Public class DuctLining
Represents Lining applied to the inside of a given duct, fitting or accessory.
Public class DuctLiningType
This class represents a duct lining type in Autodesk Revit.
Public class DuctPressureDropData
The input and output data used by external servers for calculation of the duct pressure drop.
Public class DuctSettings
The duct setting class.
Public class DuctSizeIterator
An iterator to a set of MEP duct sizes from DuctSizes.
Public class DuctSizes
Class RbsDuctSizes being used to store the duct sizes
Public class DuctSizeSettingIterator
An iterator to a set of items from DuctSizeSettings. Each item is a KeyValuePair(DuctShape::Enum, DuctSizes).
Public class DuctSizeSettings
Duct sizes settings
Public class DuctType
A duct type element.
Public class FlexDuct
A flex duct in the Autodesk Revit MEP product.
Public class FlexDuctType
A flex duct type in the Autodesk Revit MEP product.
Public class MechanicalEquipment
Provides access to the Mechanical Equipment in Autodesk Revit MEP.
Public class MechanicalFitting
A mechanical fitting in the Autodesk Revit MEP product.
Public class MechanicalSystem
A mechanical system element.
Public class MechanicalSystemType
Base class for duct system types
Public class MechanicalUtils
General utility methods in the Autodesk Revit MEP product.
Public class MEPBuildingConstruction
Construction definition for Project Information.
Public class MEPBuildingConstructionSet
A set that contains MEPBuildingConstructions.
Public class MEPBuildingConstructionSetIterator
An iterator to a MEPBuildingConstruction set.
Public class MEPSection
A section in the Autodesk Revit MEP product.
Public class MEPSpaceConstruction
Construction definition for Space.
Public class Space
Provides access to the space topology in Autodesk Revit.
Public class SpaceFilter
A filter used to match spaces.
Public class SpaceSet
A set that can contain any type of object.
Public class SpaceSetIterator
An iterator to a set.
Public class SpaceTag
Provides access to the space tag in Autodesk Revit.
Public class SpaceTagFilter
A filter used to match space tags.
Public class SpaceTagType
An object that represents a Space Tag style.
Public class Zone
Provides access to the Zone Element in Autodesk Revit.

Interfaces

Interface Description
Public interface IDuctFittingAndAccessoryPressureDropServer
Interface class for external servers implementing duct fitting and duct accessory coefficient calculation.
Public interface IDuctPressureDropServer
Interface for external servers implementing duct pressure drop calculation.

Enumerations

Enumeration Description
Public enumeration ComponentClassification
An enumerated type lists all MEP component classification. This attribute describes the general purpose of the MEP part component, that is used for scheduling, tagging, filter, ODBC, and etc. One component classification may include more than one part type.
Public enumeration ConditionType
An enumerated type listing all the possible condition types for a space object.
Public enumeration DuctFlowConfigurationType
An enumerated type listing all duct flow configuration types for a connector.
Public enumeration DuctLossMethodType
An enumerated type listing all duct loss calculation methods for a connector.
Public enumeration DuctShape
Enumerated type listing possible shapes for ducts.
Public enumeration DuctSystemType
An enumerated type listing all the possible duct system types for a connector object.
Public enumeration OccupancyUnit
An enumerated type listing the occupancy unit of measure for a space object.
Public enumeration ReturnAirflowType
An enumerated type listing all the possible return airflow types for a space object.
Public enumeration RiseDropSymbol
This enumeration corresponds to the rise/drop symbol used in mechanical systems
Public enumeration SpaceType
An enumerated type listing all the possible space types for a space object.
Public enumeration SystemCalculationLevel
Enumerated type listing flags that can toggle on or off certain calculations related to MEP systems.