GetLabelFor Method (ParameterType)


Gets the user-visible name for a ParameterType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static string GetLabelFor(
	ParameterType paramType
)
Visual Basic
Public Shared Function GetLabelFor ( _
	paramType As ParameterType _
) As String
Visual C++
public:
static String^ GetLabelFor(
	ParameterType paramType
)

Parameters

paramType
Type: Autodesk.Revit.DB ParameterType
The ParameterType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException Thrown when failed to get user-visible name for the input ParameterType.

See Also