Exports a list of fabrication parts into the native fabrication job (MAJ) format.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- ids
- Type: System.Collections.Generic IList ElementId
An array of FabricationPart element identifiers. Non-fabrication parts are ignored.
- filename
- Type: System String
The name given to the output file.
- addHolesForTaps
- Type: System Boolean
Set true to have holes for taps on straights added to the created fabrication job.
- idsNotExported
- Type: System.Collections.Generic IList ElementId %
An array of element identifiers that were not included in the export.
Return Value
Returns the number of fabrication parts creatged in the export. Returns zero if no valid fabrication parts or unable to create the file.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Fabrication configuration is missing. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |