MaterialId Property


The element id of the material used to create the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ MaterialId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

This value is not used when creating standalone wall sweeps. The material id of the wall sweep's type is used instead.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also