IsAdaptiveShapeHandlePoint Method


Verifies if the Reference Point is an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public static bool IsAdaptiveShapeHandlePoint(
	Document doc,
	ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptiveShapeHandlePoint ( _
	doc As Document, _
	refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptiveShapeHandlePoint(
	Document^ doc, 
	ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB Document
The Document
refPointId
Type: Autodesk.Revit.DB ElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Shape Handle Point.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also