DiagonalEdgesAreUnderconstrained Property


Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static FailureDefinitionId DiagonalEdgesAreUnderconstrained { get; }
Visual Basic
Public Shared ReadOnly Property DiagonalEdgesAreUnderconstrained As FailureDefinitionId
	Get
Visual C++
public:
static property FailureDefinitionId^ DiagonalEdgesAreUnderconstrained {
	FailureDefinitionId^ get ();
}

See Also