Sets the minor and major layout patterns as Custom, while specifying the needed parameters for this pattern.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- minorStartOverhang
- Type: System Double
The distance from the edge of the sheet to the first wire in the minor direction.
- minorEndOverhang
- Type: System Double
The distance from the last wire to the edge of the sheet in the minor direction.
- majorStartOverhang
- Type: System Double
The distance from the edge of the sheet to the first wire in the major direction.
- majorEndOverhang
- Type: System Double
The distance from the last wire to the edge of the sheet in the major direction.
- minorFabricWireItems
- Type: System.Collections.Generic IList FabricWireItem
The fabric wire items in the minor direction.
- majorFabricWireItems
- Type: System.Collections.Generic IList FabricWireItem
The fabric wire items in the major direction.
Remarks
The following properties are not used for custom fabric sheet type: - MajorDirectionWireType; - MinorDirectionWireType; - MajorSpacing; - MinorSpacing.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for minorStartOverhang is not a number -or- The given value for minorEndOverhang is not a number -or- The given value for majorStartOverhang is not a number -or- The given value for majorEndOverhang is not a number |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for minorEndOverhang must be between 0 and 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for majorEndOverhang must be between 0 and 30000 feet. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |