DeleteViewport Method


Removes a viewport from the sheet by deleting it from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void DeleteViewport(
	Viewport viewport
)
Visual Basic
Public Sub DeleteViewport ( _
	viewport As Viewport _
)
Visual C++
public:
void DeleteViewport(
	Viewport^ viewport
)

Parameters

viewport
Type: Autodesk.Revit.DB Viewport
The viewport that will be deleted and removed from the sheet.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also