ParameterElement Class


An Element that stores a user-defined parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public class ParameterElement : Element
Visual Basic
Public Class ParameterElement _
	Inherits Element
Visual C++
public ref class ParameterElement : public Element

Remarks

Revit supports both built-in and user-defined parameters. Built-in parameters ship with the application, and they are not stored in Revit documents. User-defined parameters are dynamically created, and they are stored in the documents that use them, wrapped in ParameterElement objects. Different subclasses of ParemeterElement represent different kinds of user-defined parameters.

Inheritance Hierarchy

See Also