Division Operator


Divides the specified vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static XYZ operator /(
	XYZ left,
	double value
)
Visual Basic
Public Shared Operator / ( _
	left As XYZ, _
	value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator /(
	XYZ^ left, 
	double value
)

Parameters

left
Type: Autodesk.Revit.DB XYZ
The value to divide the vector by.
value
Type: System Double
The vector to divide by the value.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when source is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentException Thrown when the specified value is an infinite number or zero.

See Also