MaterialId Property


The Id of the element assocated with this material in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public ElementId MaterialId { get; }
Visual Basic
Public ReadOnly Property MaterialId As ElementId
	Get
Visual C++
public:
property ElementId^ MaterialId {
	ElementId^ get ();
}

Remarks

It is possible that no specific material is applied to a face, in which case the default material is used, and this property returns an InvalidElementId.

See Also