Prints a set of views with a specified view template and default print settings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- views
- Type: Autodesk.Revit.DB ViewSet
The set of views which need to be printed.
- viewTemplate
- Type: Autodesk.Revit.DB View
The view template which apply to the set of views.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view. |
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the view set to be printed is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the view set contains a a null reference ( Nothing in Visual Basic) element. |
Autodesk.Revit.Exceptions ApplicationException | Thrown when at least one view from the view set could not be printed. |
Autodesk.Revit.Exceptions OperationCanceledException | Thrown when print is cancelled by event handler. |