Parameter Property


The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public ElementId Parameter { get; set; }
Visual Basic
Public Property Parameter As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ Parameter {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also