PointLoad Class


An object that represents a force/moment applied to a single point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public class PointLoad : LoadBase
Visual Basic
Public Class PointLoad _
	Inherits LoadBase
Visual C++
public ref class PointLoad : public LoadBase

Examples

Copy C#
private void Getinfo_PointLoad(PointLoad pointLoad)
{
    string message = "Point Load :";

    // Get the load case name
    message += "\nLoad case for load: " + pointLoad.LoadCaseName;

    //get the three dimensional force applied to the point load
    message += "\nForce: (" + pointLoad.ForceVector.X + ", " +
             pointLoad.ForceVector.Y + ", " + pointLoad.ForceVector.Z + ")";

    //get the three dimensional moment application to the point load
    message += "\nMoment: (" + pointLoad.MomentVector.X + ", " +
             pointLoad.MomentVector.Y + ", " + pointLoad.MomentVector.Z + ")";

    //get the three dimensional coordinates of point load
    message += "\nPoint load location: (" + pointLoad.Point.X + ", " +
             pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")";

    TaskDialog.Show("Revit",message);
}
Copy VB.NET
Private Sub Getinfo_PointLoad(pointLoad As PointLoad)
    Dim message As String = "Point Load :"

    ' Get the load case name
    message += vbLf & "Load case for load: " & Convert.ToString(pointLoad.LoadCaseName)

    'get the three dimensional force applied to the point load
 message += vbLf & "Force: (" & Convert.ToString(pointLoad.ForceVector.X) & ", " & Convert.ToString(pointLoad.ForceVector.Y) & ", " & Convert.ToString(pointLoad.ForceVector.Z) & ")"

    'get the three dimensional moment application to the point load
 message += vbLf & "Moment: (" & Convert.ToString(pointLoad.MomentVector.X) & ", " & Convert.ToString(pointLoad.MomentVector.Y) & ", " & Convert.ToString(pointLoad.MomentVector.Z) & ")"

    'get the three dimensional coordinates of point load
    message += vbLf & "Point load location: (" & Convert.ToString(pointLoad.Point.X) & ", " & Convert.ToString(pointLoad.Point.Y) & ", " & Convert.ToString(pointLoad.Point.Z) & ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

See Also