SetRules Method


Sets the rules, all of which must be satisfied for a given element to pass this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public void SetRules(
	IList<FilterRule> rules
)
Visual Basic
Public Sub SetRules ( _
	rules As IList(Of FilterRule) _
)
Visual C++
public:
void SetRules(
	IList<FilterRule^>^ rules
)

Remarks

The rules are applied in the order given. If an element fails to pass a certain rule, no further testing is done.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException One of the given rules refers to a parameter that does not apply to this filter's categories. -or- One of the rules in the given array is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also