For a spiral, the overall height.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: height must be positive. |
Autodesk.Revit.Exceptions DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InvalidOperationException | This Rebar is not an instance of a spiral shape. -or- This method applies only to shape driven rebar. |