FromPosition Property


The "from" position of spatial element connecting calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public XYZ FromPosition { get; set; }
Visual Basic
Public Property FromPosition As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ FromPosition {
	XYZ^ get ();
	void set (XYZ^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: fromPosition must be on the opposite side of the family's host from the "to" position.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also