Id Property


The id of the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public int Id { get; set; }
Visual Basic
Public Property Id As Integer
	Get
	Set
Visual C++
public:
property int Id {
	int get ();
	void set (int value);
}

Field Value

If the wall sweep belongs to a vertically compound structure, this must be a non-negative value. If the wall sweep belongs to a sweep defined outside of compound structures by UI or API the id will typically be -1 and is not used.

See Also