Converts a group of ModelCurves to equivalent DetailCurves.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view where the new lines will be created. The lines are projected on the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
- modelCurves
- Type: Autodesk.Revit.DB ModelCurveArray
The model curve array to be converted.
Remarks
This operation will create new DetailCurves with the same geometry of the original model curves' geometry. The model curves will be deleted from the document. If the model curves do not lie in a plane parallel to the view, their geometry will be projected to the view.
Exceptions
Exception | Condition |
---|---|
System ArgumentNullException | Thrown when the input argument is a null reference ( Nothing in Visual Basic) . |
System ArgumentException | Thrown when view is invalid to create DetailCurves on it. |
System InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view. |