Creates empty analysis results primitive associated with a curve and a transform.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve
- Type: Autodesk.Revit.DB Curve
Curve to be associated with the primitive. %curve% does NOT correspond to actual Revit geometry, i.e. it cannot be associated with reference; otherwise the other overload of the method must be used (taking "reference" as the input)
- trf
- Type: Autodesk.Revit.DB Transform
Conformal Transform to be applied to %curve%.
Return Value
Unique index of primitive for future referencesExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input curve points to a helical curve and is not supported for this operation. -or- Argument trf is not a conformal transform (see property Revit::DB::Transform::IsConformal) |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |