GetFirstProfilePoint Method


If a point was used to define the first profile, returns a copy of that point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017

Syntax

C#
public XYZ GetFirstProfilePoint()
Visual Basic
Public Function GetFirstProfilePoint As XYZ
Visual C++
public:
XYZ^ GetFirstProfilePoint()

Return Value

The first profile point if it was set.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException This surface element does not use a point to define the first profile.

See Also