RuleValue Property


The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public double RuleValue { get; set; }
Visual Basic
Public Property RuleValue As Double
	Get
	Set
Visual C++
public:
property double RuleValue {
	double get ();
	void set (double value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The given value for ruleValue is not finite -or- When setting this property: The given value for ruleValue is not a number

See Also