CanSplitStraight Method


Validates if the straight can be split into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017 Subscription Update

Syntax

C#
public bool CanSplitStraight(
	Document document,
	ElementId partId,
	XYZ position
)
Visual Basic
Public Function CanSplitStraight ( _
	document As Document, _
	partId As ElementId, _
	position As XYZ _
) As Boolean
Visual C++
public:
bool CanSplitStraight(
	Document^ document, 
	ElementId^ partId, 
	XYZ^ position
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document.
partId
Type: Autodesk.Revit.DB ElementId
Id of the straight to split.
position
Type: Autodesk.Revit.DB XYZ
The position to split in the straight.

Return Value

Returns true if valid otherwise false if the straight cannot be split.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also