Geometry curve of the curve element.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
Remarks
When setting this property, any curves that this curve is currently joined to will affect the result -
the final geometry of this curve and of the joined curves may change.
To avoid the effect of existing joins, use
SetGeometryCurve(Curve, Boolean)
with true passed ot overrideJoins.
After the curve geometry is set, other nearby curves may join to the new curve geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown if the argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentNullException | Thrown if the argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints. |