Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
- OST_MassInteriorWall
- OST_MassExteriorWall
- OST_MassExteriorWallUnderground
- OST_MassRoof
- OST_MassFloor
- OST_MassSlab
- OST_MassShade
- OST_MassGlazing
- OST_MassSkylights
- OST_MassOpening
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- massSubCategoryId
- Type: Autodesk.Revit.DB ElementId
The mass sub-category to be checked.
Return Value
True if the mass sub-category falls within the list, false otherwise.Remarks
This excludes sub-categories which are not actually sub-categories that can be assigned to surfaces, such as OST_MassWallsAll for example.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |