Export Method (View3D)


Exports one 3-D view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2014

Syntax

C#
public void Export(
	View3D view
)
Visual Basic
Public Sub Export ( _
	view As View3D _
)
Visual C++
public:
void Export(
	View3D^ view
)

Parameters

view
Type: Autodesk.Revit.DB View3D
An instance of the 3-D view to export

Remarks

Note that the actual export process may differ depending on the type of export context used. For example, when the IModelExportContext is used, Revit is likely to perform several rounds of traversing each view, which may result in invoking the OnViewBegin/OnViewEnd method multiple times for every one view. It is because Revit draws objects in several layers (model layer, annotation layer, etc.) and will traverse each layer individually. In the most common scenario the user will receive two invocations of OnViewBegin/OnViewEnd: In the first round, all model entities will be received, while in the second round all text annotation elements will be received, if any present in the given view.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The view is not exportable, such as a template view, for example.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException The instance of IExportContext is not valid. -or- Rendering is currently not supported in the running instance of Revit. One reason for that to happen is that rendering and material libraries are not currently available.

See Also