Function Property


The function of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)

Syntax

C#
public MaterialFunctionAssignment Function { get; set; }
Visual Basic
Public Property Function As MaterialFunctionAssignment
	Get
	Set
Visual C++
public:
property MaterialFunctionAssignment Function {
	MaterialFunctionAssignment get ();
	void set (MaterialFunctionAssignment value);
}

Field Value

The default is MaterialFunctionAssignment.None.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also