DeckProfileId Property


The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public ElementId DeckProfileId { get; set; }
Visual Basic
Public Property DeckProfileId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ DeckProfileId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Field Value

The default is InvalidElementId.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also