SetDistanceToTargetHostFace Method


Sets the distance from the RebarConstrainedHandle to the target Host Element surface. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace.'

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public void SetDistanceToTargetHostFace(
	double offset
)
Visual Basic
Public Sub SetDistanceToTargetHostFace ( _
	offset As Double _
)
Visual C++
public:
void SetDistanceToTargetHostFace(
	double offset
)

Parameters

offset
Type: System Double
The distance is given as an offset value, the sign of which depends on Host Face direction.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException The given value for offset must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace.'

See Also