Subtraction Operator


Subtracts the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static UV operator -(
	UV left,
	UV right
)
Visual Basic
Public Shared Operator - ( _
	left As UV, _
	right As UV _
) As UV
Visual C++
public:
static UV^ operator -(
	UV^ left, 
	UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB UV
The first vector.
right
Type: Autodesk.Revit.DB UV
The second vector.

Return Value

The 2-D vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when left or right is a null reference ( Nothing in Visual Basic) .

See Also