Checks consistency of the Analytical Model.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
Document in which to perform consistency checks.
Return Value
True if run succeeded, false otherwise.Remarks
Existence of inconsistencies will not affect the return value. If inconsistencies are found, Revit will post warnings regarding those inconsistencies. This should be run from within a transaction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |