GetTotalTransform Method


Gets the total transform, which includes the true north transform for instances like import instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public Transform GetTotalTransform()
Visual Basic
Public Function GetTotalTransform As Transform
Visual C++
public:
Transform^ GetTotalTransform()

Return Value

The calculated total transform.

Remarks

For most of other instances, it simply returns the inherent transform.

See Also