DimensionPlaneNormal Property


The normal vector to the dimension plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public XYZ DimensionPlaneNormal { get; set; }
Visual Basic
Public Property DimensionPlaneNormal As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ DimensionPlaneNormal {
	XYZ^ get ();
	void set (XYZ^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: dimensionPlaneNormal is not length 1.0.

See Also