Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- right
- Type: Autodesk.Revit.DB Transform
The transformation to compare with this transformation.
Return Value
True if the two transformations are equal; otherwise, false.Remarks
The tolerance is applied memberwise for comparison.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the specified transformation is a null reference ( Nothing in Visual Basic) . |