AddResource Method (String)


Adds an external resource to the folder path by supplying the resource name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public void AddResource(
	string resourceName
)
Visual Basic
Public Sub AddResource ( _
	resourceName As String _
)
Visual C++
public:
void AddResource(
	String^ resourceName
)

Parameters

resourceName
Type: System String
The unique short name of external resource.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also