SketchPlane Property


Override the SketchPlane property of CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public override SketchPlane SketchPlane { get; set; }
Visual Basic
Public Overrides Property SketchPlane As SketchPlane
	Get
	Set
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
	SketchPlane^ get () override;
	void set (SketchPlane^ value) override;
}

Remarks

CurveByPoints has no associated SketchPlane. Getting this property returns a null reference ( Nothing in Visual Basic) . Setting it causes an InvalidOperationException.

See Also