GetAllTypes Method


Gets all the analytical connection types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public static ISet<ElementId> GetAllTypes(
	Document doc
)
Visual Basic
Public Shared Function GetAllTypes ( _
	doc As Document _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetAllTypes(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB Document
The document where the analytical connection types come from.

Return Value

All the types in this document, empty if none.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also