Reload Method


Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public ExternalResourceLoadStatus Reload(
	KeyBasedTreeEntriesLoadResults loadResults
)
Visual Basic
Public Function Reload ( _
	loadResults As KeyBasedTreeEntriesLoadResults _
) As ExternalResourceLoadStatus
Visual C++
public:
ExternalResourceLoadStatus Reload(
	KeyBasedTreeEntriesLoadResults^ loadResults
)

Parameters

loadResults
Type: Autodesk.Revit.DB KeyBasedTreeEntriesLoadResults

If provided, Revit will use this object to store any errors or warnings that were encountered. Note that if the KeyBasedTreeEntries in the model are already up to date, no errors or warnings will be added to this object.

This argument may be a null reference ( Nothing in Visual Basic) .

Return Value

Returns the outcome of the reload operation.

Remarks

Revit will try to read KeyBasedTreeEntries from the resource reference stored within the KeyBasedTreeEntryTable. If the operation fails, the table will be unchanged.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ModificationForbiddenException The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions ModificationOutsideTransactionException The document containing this KeyBasedTreeEntryTable has no open transaction.

See Also