ThermalProperties Property


The calculated and settable thermal properties of the RoofType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
	Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
	ThermalProperties^ get ();
}

Remarks

Returns a null reference ( Nothing in Visual Basic) if the roof has no thermal properties. Curtain roofs do not store thermal properties.

See Also