Resolves failures by deletion of elements related to the failures.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idsToDelete
- Type: System.Collections.Generic IList ElementId
Ids of elements to be deleted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Resolution of the failures by deleting idsToDelete is not permitted |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |