GetMaterialThickness Method


Gets material thickness from its material/gauge identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public double GetMaterialThickness(
	int materialId,
	int gaugeId
)
Visual Basic
Public Function GetMaterialThickness ( _
	materialId As Integer, _
	gaugeId As Integer _
) As Double
Visual C++
public:
double GetMaterialThickness(
	int materialId, 
	int gaugeId
)

Parameters

materialId
Type: System Int32
The material identifier.
gaugeId
Type: System Int32
The gauge identifier within the specified material.

Return Value

The thickness of the material/gauge.

See Also